Урок - Обновить jquery до версии 1.4, 1.5, 1.6 в Drupal6

Главная » Курсы » Курс Drupal 6, Управление » Урок - Обновить jquery до версии 1.4, 1.5, 1.6 в Drupal6

Обучающий онлайн курс
Drupal 6, Управление

Лицензия: Копирование запрещено.

Для того чтобы обновить версию jQuery до версии 1.4, 1.5, 1.6 в Друпале необходимо сначала установить модуль jQuery_update. Этот модуль обновляет версию jquery до 1.3.2, в принципе этого хватает для различных баннеров, и каруселей, и создания визуальных эффектов, но в более поздних версиях jquery изменились функции работы с ajax. Итак, мы установили jquery_update, теперь заходим в папку с модулем, копируем файл jquery в папку replace, так чтобы имя файла jquery было с версией, например jquery-1.5.2.js Чтобы переопределить файл jquery нужно зайти в файл модуля jquery_update.module и заменить функцию jquery_update_jquery_path() на следующий код:

  1. function jquery_update_jquery_path() {
  2. $curr_uri = request_uri();
  3. if (strpos($curr_uri,'admin')>0 || strpos($curr_uri,'edit')>0 || strpos($curr_uri,'add')>0){
  4. $jquery_file = array('none' => 'jquery.js', 'min' => 'jquery.min.js');
  5. return JQUERY_UPDATE_REPLACE_PATH .'/'. $jquery_file[variable_get('jquery_update_compression_type', 'min')];
  6. }
  7. else {
  8. $jquery_file = array('none' => 'jquery-1.5.2.js', 'min' => 'jquery-1.5.2.min.js');
  9. return JQUERY_UPDATE_REPLACE_PATH .'/'. $jquery_file[variable_get('jquery_update_compression_type', 'min')];
  10. }
  11. }
‹ Создание ленты новостей на Друпале Вверх Темизация Drupal (стилизация, шаблоны) ›